Jump to content
Barnaby

TD Ameritrade stream not showing "Last"

Recommended Posts

Hello,

Former long time QT user, in process of trying out MT.  Using a TD stream.  I use TOS as my primary platform. 

XIV isn't accurately streaming "last" on the stream, just bid/ask.  It appears that a aggregate sum of last is getting streamed through every 30 seconds or so.   I tried unchecking the "Stream Tick Quotes" box on the account config screen and logging on/off a few times.  Searched through forum to see if anyone else has this issue to no success.  I haven't encountered this issue with any other ticker.

Not a paid user (yet), in case that's relevant.  

Thanks if you can help. 

Share this post


Link to post
Share on other sites

It looks like there's an issue with their data feed today. I will let them know. Note, TOS uses a different data feed

  • Like 1

Share this post


Link to post
Share on other sites

Thanks much Jerry.  It's been that way every since I've been using MT, it's never streamed correctly.  I've been using TOS to get around it.   Indeed, I can tell by using my TOS feed that there's something amiss.

I've been testing a few other tickers and it appears that only the Credit Suisse Velocity Shares ETNS have this issue.  TVIX does the same thing as does DGAZ.  Perhaps that will help.

Share this post


Link to post
Share on other sites

Jerry, XIV is streaming in real time now, just checked it this morning.  Did you contact TD and get this fixed or did it just happen to fix itself?

Either way, thanks for your help.  If it keeps streaming right, you've got a long time subscriber.  I miss QT alot. 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now


×