Jump to content
Medved Trader Forums

Recommended Posts

Occasionally MT uses a lot of CPU on my computer. It comes and goes - I haven't figured out what brings it on or when it leaves. It is not related to busy times in the market. Currently (10:15 AM PST on a Tuesday), Medved Trader is using about 85% of my laptop's CPU. Normally it uses about 10 or 15% or so.

I don't know where to find the version I'm running currently, but it is the latest one I was prompted to download (a day or two ago, I believe).

Link to post
Share on other sites

I tried adding MT as an exception in Avast, and it didn't make a difference. I also shut my antivirus off for a few minutes, and it didn't help.

I minimized all MT windows, and that brought the CPU load from MT quickly down from about 80% to less than 5%. Unfortunately, restoring the windows caused the CPU load to move back up.

Link to post
Share on other sites
  • 5 months later...

 Saw this post and tried that minimize thing.

 

 Indeed, reduces cpu usage sharply, from the 50% average range to 15% or less!

 

 I have a pretty fast video card, so don't know what MT is doing to hog so much cpu.

 

 I'm using mini charts, so I assume they are the culprit, but you'd know better.

 

 Isn't there something that can be done about this high CPU? I run other apps (tws and TOS) and it bogs down the machine.

 

 Less frequent updating of mini chart poss? Say every few seconds instead of constantly, user can select delay?

 

 PS also back to using a full 2 gig of ram, seems a lot . 30 day setting on data store. 1 day consolidation.

Link to post
Share on other sites

 did notice something odd. with Firefox closed your cpu usage is much lower.  not sure the reason here.

 

 edit: now up to 2.3 Gig of ram.  Really?

 

 lets say I have 150 symbols, I have less.

 

 thats 15 meg per symbol. with only todays action as tick data.

 

 I know theres other overhead, so call it 10 meg.   I don't get it.

Link to post
Share on other sites

don't know about Firefox. We certainly don't do anything special for it.

 

when minimized, the charts do not update, so they don't use CPU. Same with portfolios. So if you have some portfolios updating simply so you can get alerts, I would minimize those. 

 

We do have internal throttling of chart and inline chart updating. Will add some user control for that in upcoming versions

 

As for memory - which setting exactly are you looking at?  If regular Windows Task Manager on Windows 7, are you looking at 

Working Set (Memory)

Memory (Private Working Set)

 

something else?  A lot of those values are not quite what they seem.

Link to post
Share on other sites

 Looking at both memory readings.   Right now, they are at  2 gig 1.8 gig  and commit set to 1.9 gig.

 

 Thinkorswim for example, a java app, using only 1 gig , and  I have quite  few windows open . Of course they don't cache all the data, I get that.

 

  If I was running only MT, cpu usage would probably not be an issue, but  the spiking to 50% every  few seconds , even on a quad core, does seem to cause performance issues.   Not sure how much control you have of this , in whatever dev platform you're using.

 

 

 Normally I wouldn't care, but I'm noticing other apps lagging because MT is taking up so much cpu.  For example , moving the cursor in TWS (IB)  gets slow.

 

 As for firefox, I don't think theres a direct connection , but it looked like MT ran better when FF was closed. Who knows. I created a new clean profile in FF just in case there was something in there causing some system slowness.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...