Jump to content
Medved Trader Forums

PROBLEM: Microsoft Security Essentials & Windows Defender


Jerry Medved
 Share

Recommended Posts

It has come to our attention that Microsoft Security Essentials & Windows Defender cause problems with MT. They basically cause drastic slowdowns from the first moment MT is started. Not tied to network communication, etc... Just extreme slowdown.  For example, startup time for MT goes from 30 to 40 seconds to 5 minutes

If you are using Microsoft Security Essentials, Windows Defender, or another antivirus or security program that is causing slowdown for MT, you will want to exclude MT from the scans. At least with MSE, it does fix the problem.

If using Windows Defender, refer to the following link:
https://www.medvedtrader.com/www/frontend/blog/Windows-Defender-Exclusions-CU

For Microsoft Security Essentials:

  1. Open Microsoft Security Essentials
  2. Click on the SETTINGS tab.
  3. Click on "Excluded processes"
  4. Either just enter "C:\Program Files\Medved Trader\MT.EXE" in the Process names: field or click on the BROWSE button on the right side of that field and navigate to the same path.

You also have to exclude the folders used by MT

  1. Click on "Excluded files and locations"
  2. Add the following folders to be excluded (NOTE: these are for Windows 7 and up.  Older OS may have different locations. Email us for help)

    C:\ProgramData\2GK\Medved Trader

    C:\Users\<Your Windows Login Name>\AppData\Local\2GK\Medved Trader

    C:\Users\<Your Windows Login Name>\AppData\Roaming\2GK\Medved Trader

I don't know if excluding a particular directory excludes sub-directories. If not, then would want to also add:

          C:\Users\<Your Windows Login Name>\AppData\Local\2GK\Medved Trader\Temp\Compile

          C:\Users\<Your Windows Login Name>\AppData\Local\2GK\Medved Trader\Temp\Update

For help with Microsoft Security Essentials - excluding folders, please refer to this:
http://answers.microsoft.com/en-us/protect/wiki/mse-protect_scanning/how-to-exclude-a-filefolder-from-microsoft/26f2810a-47fd-40d8-b35e-3740f00fce85

 

 

  • Like 2
Link to comment
Share on other sites

  • 2 weeks later...
  • 1 year later...

They seem to hook into the C# runtime environment and monitor every line of code that executes.  That adds huge overhead.  For your everyday programs that just have a few windows and in general don't use much CPU, that is not a problem.  However, when doing a lot of computations and in general heavily using the CPU, that becomes a huge problem. MT does a performance check at the start. Normally, it takes 15 to 25 milliseconds on most computers.  When Microsoft stuff is causing problems, the same check will take 1400 milliseconds. Needless to say it makes the program run extremely sluggishly.

Not all security software cause the problems.  Microsoft stuff and sometimes BitDefender just seem to be the most common culprits.

 

Link to comment
Share on other sites

  • 2 months later...
  • 1 year later...
  • 3 years later...

Jerry, I am using Windows Defender and Windows 11 Home but it is reporting a virus when I start Medved Trader.  And MT goes to the setup window when I start it.  After that MT won't load my Layouts.  It just says it was unable to load them.  

The first virus that was Sabsik TE.A!ml couldn't be removed without a reboot cleaning.  Then when I started MT I got the virus Wacatac.B!ml plus the first one.  I'm afraid to make an exemption for MT if these viruses keep popping up.  They seem to be in dll files in an userAPP/temp/........dll file in my user folder.

Edited by WallyW
Link to comment
Share on other sites

UPDATE:  I switched MS Defender to BitDefender and it seems to play fine with MT and is not reporting any viruses.  But I am having to rebuild my charts and quote list as something happened to my Layouts and my backup is too old.

Link to comment
Share on other sites

Apparently.  There are no files in the MT backup folder even though I see it saying it is backing up every time I close it.

UPDATE: Thought I should check the import/restore one more time and I found a backup from yesterday that had everything.  So, I'm back in business.   Thanks, Jerry.

Edited by WallyW
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...