Jump to content
Medved Trader Forums
Doug Hayman

DOM orders not displayed on Chart (and some other nuances)

Recommended Posts

Hi Jerry,

I'm paper trading the MES eMicro on IB.  When I add a limit order on the DOM and click the GREEN checkmark to submit order to broker, the order is delivered to my broker fine, but several things are not happening:

1) The Limit order is not displayed visually on either my intraday or historical chart;

2) The Limit order on the DOM remains in the BUY ORDER (or SELL ORDER) column.  and does not display as it should in the BUYS (or SELLS) column;

The Limit Order executes at defined limit price at IB, shows up in my MT and IB ACCOUNT VIEW OK, but the order remains in the DOM in the BUY ORDER (or SELL ORDER) column.

Any clue here?

Thanks in advance.

Share this post


Link to post
Share on other sites

1) make sure that each chart is enabled for trading, has the correct account selected, and on the OPTIONS, has the trading options, "Adjust Scale/Trans" is selected

2) that is not how DOM window works. The order does not change locations. It just changes colors. 

3) the order remains on DOM after executing - Yes, but does it show that it is filled? and does it hide after 20 seconds or whatever period you set on SETTINGS / TRADING / GENERAL for "# of seconds that a filled order remains on the Chart/DOM"

Share this post


Link to post
Share on other sites

Jerry,

1) Both my charts are enabled for Trading;

2) The submitted order does NOT change color.

3) The DOM does NOT show that order is filled.  The original limit order (which never changed color) is remaining in the BUY ORDER (or SELL ORDERS) DOM column.  Also, it does NOT hide after 20 seconds (which is my default setting).

So, I used DOM with ticker SPY, and all works correctly.  The problem is occurring with IB symbol @MES19:GLOBEX.

 

Share this post


Link to post
Share on other sites

symbols probably do not match up. On the Account View screen, Transactions, what is the exact symbol shown on the transaction?

Share this post


Link to post
Share on other sites

On account view screen, the symbol is showing as "MESM19:*5".  Not sure what the "*5" signifies other than the dollar value associated with 1 point/1 contract of MES.

All of my screen are Linked, btw.

Share this post


Link to post
Share on other sites

P.S.  When I use symbol "@MES19:*5", then the DOM and Charts behave fine.  Is that the symbol nomenclature I should be using for the micros?

Share this post


Link to post
Share on other sites

ok, that is why. I will check on it.

2 minutes ago, Doug Hayman said:

P.S.  When I use symbol "@MES19:*5", then the DOM and Charts behave fine.  Is that the symbol nomenclature I should be using for the micros?

shouldn't have to. I will check why that is happening.  You should just use @MES19

Share this post


Link to post
Share on other sites

it would be due tot he order of events. If the symbol is read in and quoted first via account view with the incorrect version, it won't work with the other. have to clean that up

Share this post


Link to post
Share on other sites

Apologies, @MESM19 does get data (I was using @MES19 - typo).  However, same problems above occur on DOM when trading symbol @MESM19.   Again, I'm using @MESM19:*5 now, and all works end-to-end.

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


×
×
  • Create New...