Jump to content
Medved Trader Forums

Webull - Flatten Order Does Not Work


tuxnix
 Share

Recommended Posts

Hi, 

I have tried to flatten positions multiple times over several months without success on Webull. I placed the below live order to test the flatten feature.

11:13:56 - Placed a live buy order for testing
11:15:57 - Manually placed a sell limit order to test the flatten feature
11:20:12 - 11:20:19 - Attempted to flatten position multiple times without successful 
11:20:25 - I manually canceled the sell limit order
11:20:31 - 11:20.37 - Again, attempt to flatten position multiple times without 
11:20:43 - I manually placed a sell market order to close the position 

image.png.7c82607999e0dda465dda6e373f76113.png

Any thoughts is appreciated.

Edited by tuxnix
wrong time included
Link to comment
Share on other sites

Hi Jerry,

The flatten feature did not submit a cancelation for the sell limit order. I manually canceled that order and tried to flatten again, and Medved trader did not submit a market order to close out. I have provided more detail below and screenshots from Medved trader and Webull.

Please correct me if I am wrong. I understand that the flatten feature should cancel any pending orders and submit a market order to close the position. 

From 11:20:12 to 11:20:19, I attempted to flatten the order, which should cancel the sell limit and place a market order to close out. This did not happen. So, I manually canceled the sell limit order at 11:20:25. Webull accepted my manual cancelation. From 11:20:31 - 11:20:37, I tried again to flatten the order without success. So I manually submitted a sell market at 11:20:43 to close out.

Please note the screenshots from Medved Trader is PST and WeBull is EST time zones.

image.thumb.png.47f1077ef2b949d10fee93b43d779f32.png

Link to comment
Share on other sites

it will first cancel any open orders, then send the sell order. But if the open orders do not cancel, then it will fail. 

I need to get the log file to see what the problem is. Please do the following:

Go to FILE / HELP => Send Log/Settings to support menu (from Dashboard or Portfolio)

And add this Post’s URL in the comment. 

Link to comment
Share on other sites

Hi Jerry,
I thought that might be the problem based on the first screenshot in the thread. I realize it's after hours, and the market is closed. I installed the beta and tried, but fear the same result based on the below screenshot. I'll try again tomorrow and report back. 


Thanks for your help!

image.png.1eb8c54c948f04efa925ccf4b310515f.png

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...