Jump to content
Medved Trader Forums

Settings: decimals after the point, Sub-total format and other format issues


elfabre
 Share

Recommended Posts

It may be just me, but I got some troubles in setting the number of decimals after the point.
I simply changed the default format string (Setting->General->Date & Numeric format)

#,###,###,##0.00##

to this one:

#,###,###,##0.00

Generally, it did work for the Portfolio, reducing the decimals to only 2, but not in the Sub-totals!

More puzzling to me appeared the option in (Setting->Apperance->Other) named "Decimal Alignment-# of integer Digits"; what is that supposed for ?
All I know is that, when I changed it to 2, it fixed the Sub-totals decimals, too. Why so? Is this option conflicting/repetition with the previous one?

Since I was there, I also clicked the option named "Omit +/- in Coloured cells". Again, it did work in general, but got Sub-totals wrong; it removed the "-", but the negative Sub-total cells are not red coloured! So, how do I know if a total is positive or negative? (QT just leaves sign on subtotals).

The switch named "Color Sub-Totals Same as Symbols" seems to have the effect to turn off/on (pls, note the off/on order) italic on Sub-Totals AND column titles fonts (rather than changing Sub-Totals colour according to Market Symbols).
 
The following switch "BOLD Sub-Totals" seems to turn on/off bold font on Sub-Totals AND column titles.

It is just my environment (italian culture on italian Windows XP SP3, Visual Style: Office 2010 Blue, Default Color Set:"Easy", Portfolio Color Set:"Sunny") or anybody else can reproduce it?

Finally, I selected "Bold this column" on the Symbol Column in the Portfolio window. Now, I got Bold font Symbols, but all symbols are also CENTERED! and there is no way back (aside from closing and reopening the Portfolio).
The column "Change $" is right justified but the Sub-total line is left justified (not so in QT!).
What about all the prices on columns like Bid/Last/Ask/High/etc.? They appear justified on the left so they get the decinal points all misaligned (but you also get smaller column width). The venerable QT apparently used a special justification which gets all the decimal points magically aligned AND left justified !

Yours,
 fabrizio

Link to comment
Share on other sites

Price Format - that applies to normal rows, but on sub-totals, we specifically omit the decimals. 
 
Controls how numbers are aligned in portfolio columns. "Decimal Alignment-# of integer Digits" - MT does not just left or right justify numbers.  It tries to align the decimal points in the numbers. This setting controls the number of digits that MT allocates for the decimals for the alignment. For example, if it is 3:
__1.12
_12.123
123.
12345
 
(and MT makes it so there is enough room on the right of the decimal for 3 digits).  This has nothing to do with decimals on sub-totals. 
 
Omit +/- on sub-totals. Yes, that needs to be fixed. Will do.
 
"Color Sub-Totals Same as Symbols" - The name of this option may need to be adjusted. It is not really colors specifically. It is all Style changes.  If set, the sub-totals are drawn same as regular rows. Where as if not set, they have their own formatting (depending on the color set). 
 
"BOLD Sub-Totals" - should not impact column titles. What MT version are you using?  Bold column captions should only happen if you right click on the column caption and select Bold Column option, in which case it should bold all contents of that column.  If that is not the case, send me your configuration:
 
go to FILE / Export Settings.  
Leave the checkboxes already checked,
Export, then email that exported file 
 
BOLD Column on SYMBOL is centering the contents - that should not happen. Will fix.
 
TOTAL and SUB-TOTALS - Change $, CHANGE %, GAIN % and some others are LEFT Justified - Will look.
 
bid/last/ask/high/etc - refer to the 2nd item above about decimal alignment. QT did the same thing, but did not let you modify the setting. Change it back to default.
Link to comment
Share on other sites

  • 1 month later...

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...