Jump to content
Medved Trader Forums

MT and MB Trading launch problem


HIGH99
 Share

Recommended Posts

A few years back, in order to run both QT and the MB Trading software at the same time, two user names were necessary, one for each program.  That was something new

as prior one user name ran both programs.  Continuing in this vain, I am continuing to use one user name to run the MB Trading Desktop Pro platform, and my second user

name to run MT.  However, if I launch MT first, and then the Desktop Pro, the Desktop Pro is locked up.  No feed comes thru.  If I launch the Desktop Pro first, followed by

MT, then both work fine, running at the same time.  Is this normal, or is there something wrong and it should not matter which software program is launched first?  Since I am

using two user names, I would not think it should matter what the launch sequence would be.  It didn't matter with QT.

Edited by HIGH99
Link to comment
Share on other sites

The quote connection to MB Trading in QT and in MT is the same.  As is the connection by MB Trading Navigator itself

The trading connection though is different. QT used components of the MBT Navigator, which made it so that you could not run QT and MBT Nav at the same time.  MT doesn't do that. It connects to the servers directly, basically same as MBT Nav does itself.  

There may be some checks that they do in MBT Nav that cause a problem if there is an existing connection. Please contact MBT Support about that. I will try checking on that as well. In case the support person does not know how MT is connecting, have them contact us and we will be glad to assist.

Link to comment
Share on other sites

Ok, I see what is happening now.  Again I am still using two different user names.  If I open/launch MT first, and then go to open MBT Desktop Pro (it is no longer called navigator),

a warning box pops up saying that I have already launched, or opened, the Desktop pro.  It thinks I am trying to open it again.  So when I then do open it, which it does,  it must think I am opening a

second attempt at Desktop Pro, and it just sits there not working.  So it must not be able to tell the difference between MT and MBT Desktop.  Their computer thinks they are one in the same.  If I

 reverse the order and open the Desktop Pro first, it works, and then MT is only getting data, I suppose, so it works as well.  I will let you dwell on this and figure out what needs to be done.  Again I am

still using two different user names.  

Edited by HIGH99
Link to comment
Share on other sites

I closed out both.  I logged into MBT Pro first using a user name.  Then I logged into MT second, using the same user name.  Both software programs are working

using the same user name.  So that is good to know.  Now, what happens if I reverse the login sequence?  Don't know, but I bet the pop up box will open saying

I have already launched MBT Pro.  I suppose I will experiment with that next. 

Link to comment
Share on other sites

No go.  Opened MT first, then opened MBT Pro second with the same user name.  No pop up box this time, but the MBT Pro is locked up and not

working.  The computer must think MBT Pro is already opened.  So in its mind the second attempt will not let me run two MBT Pro's at the same time.

Their computer obviously cannot tell the difference between MBT Pro and MT.  It thinks they are one in the same.  I will leave to you to figure this out.

Link to comment
Share on other sites

If I launch MT first with user name #1, and then launch MBT Pro with user name #2, the pop up box first appears warning me that MBT Pro is already open.

Continuing on, I then launch the PRO but it is locked up and does not work.  When using the same user name for both, and MT first, no pop up box, but same

result.  The Pro does not work.  So the immediate solution is to launch MBT Pro first followed by MT.  You may want to alert other MB Trading users of this

sequence assuming there might be some using this beta.  Perhaps I am the only one using MBT as my data source.  I have been riding you for the past two

years when MBT will be online and it is finally here.  So it seems as long as you open the two programs in the correct sequence, they both work.  Others should

be made aware of this fact.  Other than that, life is good !

Edited by HIGH99
Link to comment
Share on other sites

Wednesday morning, life is not so good.  MBT Pro is completely locked up and not receiving quotes.  MT is receiving quotes.  I called tech support, they took control over my

computer and worked on it for 25 minutes and could not find out what was wrong.  The only solution was to uninstall MT, and still MBT Pro was locked up.  So I then uninstalled

MBT Pro, reinstalled it, and it now works.  MT is not on my computer.  So I am using QT again.  Sorry, but there is some bug in there somewhere.  The tech at MBT had never

heard of MT, and I told him it was recently approved a week or so ago.  So back to the drawing board.  The two programs are not working together.

Link to comment
Share on other sites

I would like to keep trying  to get the two to work together.  Unfortunately I uninstalled MT.  Can you shoot me

a link to install it again.  They worked yesterday when using that certain launch sequence.  What happened today

I do not know.  Something with the two user names perhaps.  I don't know.  Please send me a download link.   

Link to comment
Share on other sites

you are drawing an incorrect conclusion. MT install did not have anything to do with it if MT is not running. However, when you ran MT, MT connected. MB seems to still be detecting that connection even after.  The thing that fixed it was not the MT uninstall, but rather the MB Trading Uninstall/Install.  I have a set of instructions that I will email you in a few.

Link to comment
Share on other sites

I ran MT all night for the futures using my backup user name.  By itself, with no MBT running.  Ran just fine.  When the market opened 15 minutes ago, I logged off MT.

I then logged on MBT using my primary user name.  It was working fine.  So I then opened up MT, using my backup user name, and it

was frozen.  No data coming in.  So just the opposite problem as of yesterday.  Now either one or the other seems to freeze up from getting data.  I got your email,

but I am attempting to translate it into English.  I am not computer savvy.  Meantime my QT chugs away with no problem compatibility with MBT.  

Link to comment
Share on other sites

As of Monday, things seem to have stabilized when running the two programs together.  I am continuing to use two user names to prevent any

multiple login in conflicts.  Have you communicated with MBT about this?  My contact source was not aware of Medved Trader, and they don't list

it on there lineup of outside programs.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...