Jump to content
Medved Trader Forums

Options Chain for CSIQ Won't Download.


JerryS
 Share

Recommended Posts

No options chain for CSIQ.

Getting data from TDA.

All other symbols I tried fill the chain.  CSIQ produces blank table.

Option chain at TDA is visible for this symbol at their site, so it would not make sense for me to call them.

Edited by JerryS
more detail
Link to comment
Share on other sites

I tried Reload many times.

Sometimes I waited a minute or so and tried again.  Didn't matter.

I tried other symbols and they all worked.

I looked at other settings to see if they can be different for different symbols.

Clicked on the green light/button to turn it OFF and back ON -- didn't help.

This happened at least once last week but don't remember if it was the same symbol.

So ... I tried it after reading your message, and before writing this response, and it worked.  Go figure.

A thought I had last week after similar difficulties: there must be some timing limitations when handling data back-&-forth over the phone network.  Some data operations must have a time limit/window, otherwise the operation (and therefore its channel or time slot) can be held in limbo while waiting for a response.  Because of my remote location, all communication to the outside world is via geosynchronous satellite.  One round-trip delay between earth and satellite is 240ms (and it can be longer if there is interference, or multiple hops depending on service provider at each end).  I wonder if that can cause a timing issue when data is being passed back and forth. One thing for sure -- when people talk to each other over such a network, they must not talk over each other as that will cause the system to cut on and off, resulting in each conversation being chopped on and off.

 

Link to comment
Share on other sites

if nothing shows up, that means MT could not get the chain itself (list of symbols to display). That request is not streaming. It is just an HTTP request for a page of data.  Normally wouldn't matter if a slow connection but if there was some connectivity problem at the time, it could cause it to fail

Link to comment
Share on other sites

I just filled the options table with data for CRUS and several other symbols.  All worked very quickly.

Then I tried CSIQ many times and it's blank every time.  Not even the grid loads.  Therefore I don't think it's a timing problem.  There is something specifically wrong with CSIQ.

I've noticed that when I try a new symbol that it takes a few seconds to load the grid in the options table then the data is displayed a short time later.  For symbols that have already shown options data, the grid loads immediately when I enter the symbol then the data comes in after a small delay.  Now when I load CSIQ, the grid never appears.

Does that mean that I have a corrupted temporary data file involving CSIQ?

Perhaps that temporary file can be deleted so that it can be rewritten correctly?

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...