Jump to content
Medved Trader Forums

Template drop-downs not loading


JerryS
 Share

Recommended Posts

Depending on Loading or Saving chart templates, there are two pairs of choices: a symbol (either a file folder for the case of Load, or a 3.5" floppy for the case of Save); or the words Load or Save, each with a downward pointing arrow.

The downward pointing arrows indicates that those choices each activate a drop-down list containing the file name choices for either Load or Save.  The drop-downs usually don't open, indicating the file names were never loaded into their respective lists when the program (MT) was started.

Yesterday I played with these things for a long time because I assumed these things were working as designed, but the performance didn't match the instructions in the Help file.  After fiddling with them for a long time, they started working.  But I don't have a clue what I did to make them work.

Currently, they are not working.

Link to comment
Share on other sites

I already understand all of that.  I have 7 templates which I've already saved.

I'll try again.  Read very slowly.

Early this morning I wanted to load a template on a specific chart.  So I clicked the dropdown button on that chart while expecting a list of 7 templates to appear.  Nothing happened, meaning there was no drop-down list.  So I downloaded the template anyway using the button with the folder symbol.

Now, after the market closed, I wanted to look at a specific chart (probably not the same one I looked at earlier) using a different template than the one it had.  So I clicked its template dropdown button.  A list of 7 choices came up.  Now it works, but it did not work early this morning.

Link to comment
Share on other sites

  • 2 weeks later...

Since my last comment on this subject, I've only had one time when the drop-down didn't bring up a list.

However, if I quit the program and restart it, then the list worked as expected. This was a few days ago.

This may relate to some of the problems:  Sometimes when starting the program it seemed unresponsive as no quotes would update and the green indicator wouldn't flash, then (being impatient) I would fiddle with MT to see if I could figure out why it was unresponsive.  Sometimes it would start working, and sometimes not, so I would reboot.  That's always quite annoying, but now here's the interesting part ... one day, when I was having this startup problem, a little message box opened up outside of any other MT window and was located at the lower-right corner of the screen.  That has never happened before.  It contained a message seemingly from TD Ameritrade stating that they were having problems with their data feed.

Now I'm wondering, was that message generated by MT or did it come directly from TDA?  And, when at other times the program was unresponsive, why didn't I get the same message?

FWIW, since that day, I don't recall any startup problems and the drop-downs have worked.

Link to comment
Share on other sites

That's very interesting because I had never seen that pop-up before even though I often had trouble getting any activity from TDA after starting up MT.  I would get frustrated and reboot the program then usually everything would be OK.

I even called TDA once to ask if they were having trouble and they said NO.  I don't know how they could tell so quickly unless they pinged me and looked for a response, but they didn't say they had done that and I doubt if they did because the person reached on the help line probably doesn't have the ability to do that (but I didn't think to ask them that at the time).  I assumed that if they don't get a number of complaints above a predetermined threshold then they assume it is not their problem and they make no further effort.  (I'm glad that PG&E isn't that way.  I'm at the end of one of their lines and I'm virtually always the first one to call them and let them know that the power is down.)

So, if I'm to take that message seriously then there is at least a way built into MT of determining that there is a problem but maybe it's not thorough enough (or prompt enough) because I've only seen the message once even though I've had the problem more than once.

- - -

At any rate, I don't recall having much trouble since then -- at least I'm pretty sure.  Maybe I've grown more patient.  Or maybe the complaint count at TDA exceeded a threshold above which they concluded there is a problem and they fixed it, and that's why I haven't had a problem recently.

 

Link to comment
Share on other sites

This problem (template Load or Save drop-down lists not loading) happened again today.

The setup was that I had four charts open: $SPX daily and intraday, and $VIX daily and intraday.

I was in the process of modifying a specific $SPX historical template to add SMA(320) to a group of six other SMA()s that I already had for the particular template. I wasn't doing anything with the intraday charts. During this process both the Load and Save drop-downs were working on both historical charts.

After saving the historical template changes for the $SPX chart from that chart, I decided to look at the $VIX historical chart and see if I could load the changes there. Now, clicking on the Load drop-down at that chart did not produce a list, whereas it worked before. At that point I decided that I should obtain and send a log file but I decided to do a few more tests and collect more information first. I did several things and the Load drop-down for the $VIX chart continued to not produce a list; then while attempting to look at something else I accidentally deleted the $VIX history chart, so I reloaded it. After reloading that chart, the Load drop-down worked.

Bad me -- I can't make it quit working again and now I don't have a log file taken while it wasn't working.
So, obviously, you'll have to wait for a log file showing an inoperative drop-down.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...