Jump to content
Medved Trader Forums

Timeframes issue


Recommended Posts

Dear Medved 

I am trying to watch European stocks using google data feed. I had set European Equities (CET) timeframe as a default in settings . But still charts shows not full data cause it automatically choose US Equity Market data timeframe. I had to change on chart manually all time , with is annoying and time consuming. I have tryied to change my PC time settings too  . Played with all settings , but nothing helps Could you please fix it if possible 


Thank you in Advance 


Link to comment
Share on other sites

Hi Aleksandr,

Sorry for the late reply - I was busy cleaning up the signup database this morning since someone kept trying to abuse our free first month deal and kept registering under fake emails, and forgot to reply to the forums.

We don't have Google available as a quote feed. Only as backfill. The stuff that handles automatically setting the proper timeframe is done on quotes, not backfill.  There are a few things to check and/or change:

1) Make sure that you use MT format for the symbols. For example, if you are trying to get a quote on SYMBOL on the London stock exchange, you would enter it as SYMBOL:LON  and not in whatever format used by the native datafeed. That way, MT knows which exchange it is and it should automatically set the timeframe for you in most cases.

2) If you do need to manually set the timeframe, that is done is done on the chart, not in settings.  (on the VIEW tab on the chart's toolbar)

3) If the change is supposed to be permanent for the given symbol, then do 2 things. 

  • Set the timeframe on the VIEW tab to whatever timeframe you want.
  • Click on the Timeframe selection again and select "Set Symbol Default: ...." option

You really don't want to mess with the PC Time settings. The only thing that will do is mess things up.

If you need more help, please give specifics - which quote source is selected on the portfolio? The exact symbols entered in the portfolio or on the chart that you are having an issue with.


Link to comment
Share on other sites

  • 2 weeks later...

Thank you Medved 

I did everything you advised, and it perfectly works only for USA and ENGLAND stock markets. 

But I am also watching EURONEXT (XYZ:EPA XYZ:AMS XYZ.PA XYZ.AS and so on ) Bursa Istanbul , Bovespa and other European and East Equity  markets . When I trying  to watch charts from portfolio linking , or typing them manually on charts - the time frame autocratically is set to US Equity Market . Even If  default time frame is different . I even tried to create user defined time frame , but nothing works. 

That could be great when I want to see SYMBOL:EPA - it automatically chooses European Equities time zone or could set default time frame for certain chart

Thank you in advance 

Link to comment
Share on other sites

Can you give me the specific symbols?

MT does try to automatically set the timeframe for as many symbols as it can, but it can't do all. For it to do it, you must enter the symbols in MT format. So instead of SYMBOL.PA, enter SYMBOL:PA and that should set it to CAC40 timeframe.  for ones that it does not know the timeframe, you can set the timeframe on the chart's VIEW tab (NOT in SETTINGS).  NOTE: If you just change the timeframe, that is specific to the chart. If you want to make the change for the symbol regardless of chart, then click on the timeframe dropdown a 2nd time and select "Set Symbol Default: ....".  After that, the timeframe you set as the symbol default will act the same as if MT set it.

Link to comment
Share on other sites

I did everything as You said in your previous message , but I do experience the same . May be because I used google symbol format ( I prefer google charts backfill for accuracy and data ) For Euronext XYZ :EPA :AMS :EBR :ELI , for Turkey :IST . So this could be great , if I want to see charts NEX:EPA or RNO:EPA - charts would automatically choose C40 timezone 

Link to comment
Share on other sites

what exactly did you do? because if you select Set Symbol Default for a particular timeframe on a particular chart, ijt will definitely not switch to US Market timeframe. 

Not sure what you mean by google format. Are you referring to the exchange codes? 

Can you please give me exact symbols that you are entering into MT?

Link to comment
Share on other sites

the SETTINGS screen is used for configuring timeframes. Not selecting them. The Set As Default option is only for controlling the timeframe used for status bar on dashboard and a few other places where MT needs to know the general timeframe to use when not specific to a single symbol.

Instead, on the chart itself, click on the timeframe on the VIEW tab on the chart (where you have US Equities selected in your picture) and select select European Equities (CET) (I think it is under OTHER). Then, click on Timeframe again and select the Set Symbol Default.


if you want to post in Russian, that is fine. We will respond in English (can't type in Russian). 

Which datafeed are you using for quotes? I can check to see if I can make it not set the timeframe if it is not sure. That way, it will revert to the default from SETTINGS.

Edited by Jerry Medved
updated description of default timeframe in SETTINGS
Link to comment
Share on other sites

Я попробую на русском) .То что вы написали выше - я проделываю , и это работает . Главная проблема в том что , мне приходится это делать каждый раз . Если я вбиваю символ и время не подходит , то мне приходится поправлять его каждый раз , когда я вбиваю новый символ . Не важно с залинкован ли график с портфолио , или я вбиваю вручную . Неважно где я указал настройки времени в окне графика или в опциях и что стоит по умолчанию . Проблема в том что мне приходится вручную поправлять каждый раз когда я открываю новый символ . Учитывая что я просматриваю более тысячи графиков в день . Постоянно поправлять время вручную при каждым новом символе - отнимает время и внимание. 

Для бэкфила я пользуюсь только google finance . 




4 minutes ago, Jerry Medved said:

if you use ANC:AMS right now, the quotes will not update. It will only work for google Backfill. I updated Yahoo stuff to recognize AMS in the future. If you enter ANC:AS, that will be recognized right now for Yahoo and Google (MT converts stuff it knows)

Can you do for :EBR :ELI :IST  too ? (:BR :LS :IS) Thanks 

Link to comment
Share on other sites

:EBR and :ELI (Brussels and Lissabon ) are for EURONEXT ( as :EPA and :AMS ) are good for European equities . For Example ( RNO:EPA KPN:AMS NYR:EBR CTT:ELI)

As for :IST (Istanbul )  :IS  e.g ULKER:IST ULKER:IS . Timeframe for Turkish equity is different  (9:30 AM - 12:30 PM, 2:00 PM to 5:30 PM ‡) GMT + 3 . I could not find it in timeframes 


Link to comment
Share on other sites

got most of the stuff done. As for Istanbul - are you sure about the hours? when I checked here:


they have different stuff listed. And when I look at the actual data from Google on ULKER:IST I see stuff from 9:55 to 13:00 then 13:55 to 18:00 or 18:08? Would 10:00 to 13 and then 14:00 to 18:00 be correct? (with the other stuff +/- 5 minutes showing as Ext. Hours ...

Link to comment
Share on other sites

10 hours ago, Jerry Medved said:

NOTE: there is a small issue with the Istanbul timframe that was released (if showing ext. hours). will fix in next beta

Could you please also fix for SYMBOL:PA. Seems to me it tied to CAC40 and European Equties timeframe at the same time. It automatically choose the first or second timeframe. Could you please match to European equties timeframe only .As for  SYMBOL:AS SYMBOL:BR SYBOL:LS - they are working perfect , and I am happy to see that problem is solved !!! 

Link to comment
Share on other sites

On 08.11.2017 at 9:36 AM, Jerry Medved said:

A symbol cannot be tied to 2 timeframes at the same time. What exactly are you seeing that makes you think that?

right now it is supposed to auto select CAC40. will change.

When I watch Paris stock symbols XYZ:PA  , chart selects European equities or CAC40 time frames arbitrarily . Maybe this happen because previous watched symbols was Amsterdam or Lisbon stocks ( XYZ:AM XYZ:LS ) , which are matched to European , or maybe my default time is European. Please match Paris stocks to European Equites ( CAC40 has longer time , and shows  free unfilled space ) as Amsterdam Brussels and Lisbon . Because all four traded in one exchange - Euronext , and have the same timeframe. I hope I was clear 


Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...