Jump to content
Medved Trader Forums

Raw Data missing bid/ask


QTuser
 Share

Recommended Posts

TDA is source.  Problem first noticed this morning. When click on new symbol for first time, bid/ask briefly appears then is refreshed and disappears. Time, Last and volume are displayed but not updated. Level II appears to function correctly.

 

Same setup for QT works correctly.

 

TIA

 

Cannot swear to it but believe this is related to latest update which did last evening and didn't really pay attention to whether problem was occuring before or after.

Link to comment
Share on other sites

Top left button under File which is labeled stop or start currently showing STOP but had tried clicking which changed label to start but no change to raw data ... then clicked again and label changed back to stop again with no change to symptoms I reported ...IE time, last and vol displayed but not updated, bid and ask missing.

Link to comment
Share on other sites

changing the stop/start will not in any way change the data already in MT,  I asked because if the quotes were updating, you would have current quotes from the Level I data and thus when backfill occurred, it would fill in missing data but not the period for which it already has data

 

Other than the stop/start - does the status on the Dashboard for TDA show streaming or is it red?  Are quotes updating on the portfolio?

Link to comment
Share on other sites

Backfill upadtes the time, last and volume one time but does not casue it to begin updating going foreward. Dash board status for Ameritade shows:

 

State: Streaming

Status: Running

Bandwidth: 637 and varying

LI: 30

LII: 2

BF: Blank

H.BF: Blank

Nws: Blank

Link to comment
Share on other sites

ok, seems that the quote is not updating.  If you open the chart, then after it backfills, click on the button on the chart ribbon to clear all data.  Then look on the portfolio - do the quotes come in for that symbol? Are the date/time OK on the quote or are they in the future?

 

What symbol is this for?

Link to comment
Share on other sites

Need some help as I am unclear as to how to take actions you requested.

 

As to your instructions:

 

1) Are you calling the raw data table the chart?

 

2) I do not see anything at top of raw data table which will clear data but I do see two different dahboard items labeled clear all INT Data and Clear All Hist Data .... is it one of these buttons you wish clicked?

 

 

 

 

Link to comment
Share on other sites

Thanks, since I had been talking about raw data, you threw me when talking about the chart.

 

Did the clear and backfill; raw data table symptoms remain the same; portfolio quotes and time appear to function correctly but ALL portfolio symbol quote dates are 5/19 with the exception of GABUX which is 5/20 and subtotals which are 5/21.

Link to comment
Share on other sites

Closed MT, installed the new exe, opened MT and now seem to have the problem several others mentioned in that I do have data in all my raw data fields, the date is now correct in portfolio but ALL  data in portfolio and Raw Data is very sporadic and not keeping pace with QT.

 

Level II does not seem to be updating at all.

 

Seems to only get a little bit of data once in awhile and misses most of the data, once in awhile MT seems to aggregate volume for those it missed.

Link to comment
Share on other sites

you would have to be more specific. Give specific symbol. I am running with your setup and comparing PSEC for example.  Level II matches. Raw data - you have it set to show 1000 share blocks, so it isn't going to show everything.  When I set it to show everything and compared to another source, it showed matching trades.   Tried with a few others.  

 

Also, if you are running multiple apps connecting to TDA using the same account, that in itself can cause conflicts.  Check the dashboard to make sure it is connected and the # on the Level I column shows approximately the # of symbols you have in the portfolio

 

Jerry

Link to comment
Share on other sites

I happened to be using PSEC also ... apparently in process of prior exercise, I unknowingly changed from trades .. I have set back to trades. So operator error on that one.

 

Also just noticed that the order of market makers is reversed between QT and MT, so that accounts for the comparison difference I noticed.

 

Apologize for that. So ATM, all issues corrected.

 

Thanks

Link to comment
Share on other sites

that may just be differences in the datafeed. You have your settings set for regular consolidated quotes from TDA, not tick quotes.  So each row may represent multiple trades. TDA servers can consolidate a bit differently for each connection.  You can go to settings, setup accounts, and select TDA and check the box to get tick quotes.

Link to comment
Share on other sites

Both QT and MT show the change in volume in the volume column of raw data by default. Assuming the total volume is the same, if one row is different, then there has to be volume somewhere before or after it.

 

You can switch to show Total Volume (VIEW tab on MT). That would be better for comparison.

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...