Jump to content
Medved Trader Forums
  • 0
MTG

How to connect AB to MVT

Question

14 answers to this question

Recommended Posts

  • 0

We did add the HTTP API that in theory, should be the what AmiBroker is expecting, same as QT, in the beta version of MT: http://www.medvedtrader.com/beta

in the program you would enable the API on SETTINGS / APPLICATION /API

However, one of our users tried it with AB and said that it wasn't working. I am waiting on Tomasz to get back to us about that. Maybe you can give it a try and if it does not work, contact him too?

 

Share this post


Link to post
Share on other sites
  • 0

Still not working.  From my end I can't tell if it's an issue with MT or AB.  Not getting much response from AB help desk as they are on holidays for the moment.

Anyone else got it working?

Share this post


Link to post
Share on other sites
  • 0

the issue is that we need to add special permissions to enable the HTTP API on Windows 7. But not on Win 10. I emailed you a fix.  To have it work in the current version, just run MT "As Administrator" (right click on the shortcut used to start MT and select to run it as administrator)

Share this post


Link to post
Share on other sites
  • 0

No luck with the update Jerry, sorry to say.  I ran it as administrator, HTTP port 16244 checked, and AB has the plug in listed.

Share this post


Link to post
Share on other sites
  • 0

Don't remember - does AB let you specify the port? If not, the above will not work. If it does, is yours set to 16244 in AB as well? 

Also, did you get the Medved Trader specific plugin for AB, not just the old QT one?

If so, I need to get the log file to see what the problem is. Please do the following:
go to FILE / Export/Backup menu (from Dashboard or Portfolio)

Select “To share with others” export file protection option on top right
Leave the checkboxes already checked, and also check LOG FILE.
Export, then email me the exported file please.

Share this post


Link to post
Share on other sites
  • 0

Thanks again.  I can do that but first...

Under database settings, AB has a configuration window for the MT plug-in.  It requests inputs for:

Quotetracker* server IP (which is set at 127.0.0.1)

Quotetracker* server port  (which I have set at 16244)

*This is despite the QT plug-in having been removed. 

Would changing the server IP help?  Or does TJ need to change the config window?

 

Share this post


Link to post
Share on other sites
  • 0

Tomasz didn't change the labels :)

Server IP 127.0.0.1 must means loopback. I am assuming AB and MT are on the same computer. Send me the log. I can see in there if
1) the HTTP server is starting up

2) if it is getting the requests from AB.

Share this post


Link to post
Share on other sites
  • 0

To to other AB users - be careful with the database settings.

If you lose your database on re-start, re-configure data source to "local database" to see your data again.  Having database set to MT can cause AB to not read any of the local data.  This looks to be an AB issue, not MT.  I think the "allow mixed EOD/intraday" setting is where the problem lies.

Edited by MTG

Share this post


Link to post
Share on other sites
  • 0

as far as I know the AB plugin for MT is the same as QT, with only the detection for the HTTP server tweaked. It even still has Quotetracker references. Ping Tomasz if you are having issues

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×