Jump to content
Medved Trader Forums

Chart and raw data updates stop updating


Recommended Posts

I am frequently having and issue where the chart and raw data stop updating.  It sometimes goes for many minutes before this happens and sometimes it might be 10 seconds.  

When this happens I am able to get things running again by pressing clear all data in the chart and then pressing backfill which takes a bit of time and of course it can happen at bad times.

After recovering as described above it may run again for many minutes or may stop in 10 seconds after which I repeat the process to recover.  

I tried both questrade and dxfeed as the data source and both had the issue.

Link to comment
Share on other sites

is this only when you have the subminute charts that were discussed in the other thread?  Really should not have that type of thing.  If datafeed has to be relogged in, could have an interruption, but that should definitely not be a regular thing.  

What happens if you do NOT do clear all data?? does data start streaming again on its own? What shows in the dashboard, SOURCES tab for the datafeed at that time?

 

Link to comment
Share on other sites

I just tested without subminute charts and it still happens.  I also noticed in the raw data that the last data point is always showing up as 5 hours later.  See screenshots below.  Dxfeed was the source for these.  

Once it has stopped updating chart and raw data it does not resume on its own, I have to clear and backfill to get going again.  

I tried enabling spike filtering and set max time difference to 30 seconds but it still stops.  

I sent over logs of this as well.  

 

387331706_Screenshot2023-01-13134846.png.992beeab93b7addb327f7ff8969e28b4.png465817289_Screenshot2023-01-13134358.png.c090a97f3075d2ac4d186aeb04c0910d.png298577147_Screenshot2023-01-13134240.thumb.png.c652bb3281a01d700cfd10cfbfe4690d.png

 

Screenshot 2023-01-13 133500.png

 

Link to comment
Share on other sites

the issue is that last quote - 18:43 and 18:48.  It is screwing things up. Subsequent quotes have earlier time and do not get recorded.  Your log shows that you are getting data from multiple sources for the same symbols, which pretty much guarantees that data will get messed up.  I see data for SQQQ coming from IB, Questrade and dxFeed at the same time.  That is why you are encountering this issue.  NOTE: Pretty sure just deleting that top row in raw data will get the quotes flowing again

Link to comment
Share on other sites

your setup has one portfolio, but multiple Account View windows for different brokers.  Each one of those has "Active Quotes" checked.  This is actually exactly the reason why that option is not checked by default, because you may be getting data in each one of those from different sources and we don't want to cause conflict.  Active Quotes should only be used if broker is using same source as what you use everywhere else

Alternative - you can specify Alternate Quote Source to dxFeed on all your brokerage accounts.  In that case, all the Account View windows will use dxFeed and there will not be any conflict

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...