Jump to content
Medved Trader Forums
makincash

Application slow to catch up to market data on open

Recommended Posts

I have been finding the application is slow to get caught up to the market data as the markets open 30sec-1 minutes before the raw data time starts to match the current time. I've attached a few screen shots.  I have a 180Mb internet connection, running an amd 8730x. 32GB ram, nvme drive.  Could it be processing power slowing it down, internet, to many stocks being tracked from the data source?  

I have quite a bit open with news alerts, portfolio alerts for %changes, 14 charts, 3 raw data windows, 2 level 2, news window, 6 portfolio/watch lists  100-150 stocks in them.

I will try and load a basic profile and see if I see better response to the market data upon open.

 

Also, I am finding switching between active stocks on my main windows which are linked takes 6+ seconds for the chart and data window to populate from when I click the stock symbol.

 

5aba51ce81823_2018-02-2706_30_34-.thumb.png.ecee3dcb15ba7c41e07f5c1adce5f6e3.png5aba4e9600e6d_2018-03-2706_53_14-NDM_CA1.15(11hrs45min_1min)B_1.15A_1_16.png.6d8d02785a1ad9bad51e127372b63be0.png5aba519c14d23_2018-02-2706_30_27-.thumb.png.8867c4201b3ba636d113b0697318f3ff.png

 

Share this post


Link to post
Share on other sites

you excluded MT from all security software - both folder and "Process" if that option is available? that is by far the most common issue.

Remind me - you have a lot of alerts?

Share this post


Link to post
Share on other sites

I actually just uninstalled my AV yesterday when testing so there is nothing which would be blocking it.  Windows defender/firewall disabled.

I have alerts on at the portfolio level for 5/10%  moves and have a bunch of manually set alert lines.(6 portfolios/watch lists open)

At times it takes till over a minute (9:31 am) till Medved syncs up with the data feed.

Jeff

Share this post


Link to post
Share on other sites

Keep in mind that every portfolio level alert is basically equivalent to having that alert on every symbol in that portfolio. So just to check, try disabling the alerts and see if it starts faster.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

×