Jump to content
Medved Trader Forums

Recommended Posts

I spend every morning individually backfilling 300 symbols before the market opens. I have TD Ameritrade as my default backfill source. I have 2 portfolios 1 with 200 symbols and 1 with less than 100 symbols. I have my IB TWS platform running, along with Thinkorswim, and MT. I start at 8am CST 30 minutes before the market opens. I push the button to backfill the portfolio with 100 symbols and I see on my MT Dashboard (Source) I see symbols and beside AMTD I see numbers under BF. I do this also for my 200 symbol portfolio and I see the same thing. I then click on the first symbol (AAPL) and wait and the chart does not show any candles Premarket. I then check the symbol in TOS and IB and of course there is plenty of premarket activity for AAPL. So I right click on AAPL symbol in portfolio and click backfill AAPL and after a few seconds the chart populates. This repeats every morning I spend 30 minutes trying to get my 300 symbols filled by clicking on them individually. I can replicate this every morning for stocks. These are not just any stocks, these are stocks that show up with Premarket volume with a scanner in TOS. I mentioned this before and I sent you a file and you said there was no volume to backfill. So please believe me when I say there is an issue with this and check it as I have told you how I can verify it day after day after day..... I am so exhausted having to do this each morning. I hope every update fixes this but no change yet.

Link to post
Share on other sites

sorry, seems I have missed the post. I will read through it and get back to you.  Meanwhile, can you send me the log/settings? I am sure that will answer some of my questions. 

Go to FILE / HELP => Send Log/Settings to support menu (from Dashboard or Portfolio)

And add this Post’s URL in the comment. 

Link to post
Share on other sites

Automatic backfill (backfill all on portfolios or the backfill that occurs when you open a chart or switch symbols on a chart) will only backfill if there are "Gaps" in the data.  However, any gaps in ext. hours are NOT counted. So if that is the only data missing, it will skip.  Explicitly clicking on the BACKFILL button always does a full backfill, which is why that does fill in the data.

There is an really easy way to get around this.  Before doing backfill all, just clear the data on previous 2 days. That way, today (which won't count as a gap) and yesterday (which WILL be counted as a gap) will be missing. Then when the backfill is done, it will not skip.

Can you try that and let me know if OK? If that does fix your issue, we can see if anything can be tweaked to adjust for it.

Link to post
Share on other sites

Used your work around of clearing previous days and it worked. Thanks for the help this saved me so much time. 

Q. How do I know when MT is finished clearing the data and I should hit the backfill button? If I click the backfill button before it finishes clearing the previous days data will this mess up the data?

Edited by BlueCollarDayTrading
Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

×
×
  • Create New...