Jump to content
Medved Trader Forums

Commsec data not refreshing


inspired
 Share

Recommended Posts

I mentioned some time ago the screen would not refresh Commsec data after the computer was awoken from sleep mode.

 

From this morning,  Commsec is not refreshing at all, even after a computer start or re-start.  Clicking refresh does nothing.

 

With Yahoo as the data source, from this morning, there's no auto refresh. Will refresh only by clicking "refresh"

 

Everything works with ASX as the source, but of course the high/low data is wrong and the volumes are totally wrong.

 

Frequency is set at "1"

Link to comment
Share on other sites

I am still not set back up after the move (or more like in the middle of a move) cross country :(.  but I did just have the ASX config updated. CheckUpdates, then restart MT. 

 

As for Yahoo - on bottom of the portfolio, click on the TIME shown.. does the popup menu show Austrailan Equities selected?

 

CommSec - same thing, plus set logging to 100.  Try refreshing.  After it fails, . Please do the following:

 

go to FILE / Export Settings. 

Leave the checkboxes already checked, and also check LOG FILE.

Export, then email me the exported file please.

 

Also, need to go to:

"%LOCALAPPDATA%\2gk\Medved Trader\temp\streamers

 

And

 

Zip up and email all COMMSEC*.HTML files in that directory along with the export file.

Link to comment
Share on other sites

I am still not set back up after the move (or more like in the middle of a move) cross country :(.  but I did just have the ASX config updated. CheckUpdates, then restart MT. 

 

Still no ASX config update, checked updates saying i have latest files.

Link to comment
Share on other sites

Hi Jerry, thanks for the response, and sorry to disrupt your travel.

 

Commsec time was set to Australian equities, but Yahoo to US. I've set it to Australian equiies and now Yahoo is working.

 

As far as I can see there are no Commsec HTML files in the 2GK data folder. The path is;

      Program data\2GK\Medved Trader\

 

There are no  Temp\Streamers  folders after that, just the individual files, and the only Commsec file has a  .site suffix:

              Streamer_Commsec.site 

 

There are   5 XML files: Appsettings, chartcolorsets, coloschemes, holidays, and timetrames.

 

ASX data is still showing the day's low stock prices as higher than the day's high. Volumes are still wrong. Most stocks have a volume in double digits--instead of 6 to 8 digits--and the erroneous volume does not refresh in any case.

 

I am emailing the log file and Streamer_commsec.site files to you.

 

Regards

Inspired

Link to comment
Share on other sites

Set the Auto Refresh frequency to 5 sec, less than that will cause Commsec to Block requests. Probably not a good idea to set it to 1sec for any of the Data sources.

 

The one second refresh rate worked before, and changing it makes no difference unfortunately.

Link to comment
Share on other sites

Having just posted my responses, I re-started Medved Trader, and for the first time got a  " Medved Trader encountered an Error"

 

 

"Unable to start Streamer Commsec.Error:error compiling script for streamer Commsec.

Please contact Medved Trader technical support and provide the error details

 

AppVer: 1.0.4050.2052 ErrFlags:Log, ShowIndicator, ShowToUser

Compile Error at (0,0):Error #CS2001:Source file

'C:\Users\vic\AppData\Local\2GK\Medved Trader\Temp\Compile\wvmin4vt.).cs' could not be found

Compile Error at (0,0):Error # CS2008: No source file specified

Link to comment
Share on other sites

At the risk of hijacking this thread, can I make an observation?

 

When MT starts, CommSec is in prelogin and requires the user to manually force login before it starts streaming. Since CommSec times out after a period of inactivity, especially after the computer has been asleep, it would require the user to manually force the login to continue once awoken.

 

Therefore, can you automatically force MT to reconnect with CommSec once it has disconnected? My preference would be for the system to start and connect MT to collect the data even though I might not be available.

Link to comment
Share on other sites

Actually, when you start MT, QT should automatically start streaming with Commsec assuming you left it with streaming ON when you previously shut down.  As for the timeout, MT is supposed to detect that, but for that I need to know what to detect. I thought I put stuff in there, but will need to check further.

 

My return to the online world is taking longer than expected. I finally got landline internet access setup today as well as office furniture. Hopefully will be fully up and running this weekend.

Link to comment
Share on other sites

  • 1 month later...

I'm using Commsec for MT and I'm very sorry Jerry to say that MT is virtually useless at the moment because the updating of prices is very problematic to say the least.

 

I have noticed a very strange quirk with MT - when I know that the symbol prices are not updating (because of another provider's screen that I needed to also have open) and double click that symbol in MT, and the chart for that symbol opens - a moment later the prices update. It is not a solution however. 

 

 

Link to comment
Share on other sites

what you describe is the chart opening triggering the backfill and probably active quote subscription. As for the quotes stopping, if you see that happen, set the logging level to 200 on the dashboard (below the settings button). Then, force a refresh.  Then wait 20 sec or so and go to FILE / Export Settings. 

Leave the checkboxes already checked, and also check LOG FILE.

Export, then email me the exported file please.

 

Also, email the COMMSEC*.htm files from the following folder

C:\Users\<Your windows login here>\AppData\Local\2GK\Medved Trader\Temp\Streamers

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Guest
Reply to this topic...

×   Pasted as rich text.   Paste as plain text instead

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

 Share

×
×
  • Create New...